UrbanXConnect - Abnormal Latency - Europe West/UK – Incident details
Experiencing degraded performance
Abnormal Latency - Europe West/UK
Resolved
Major outage
Started 29 days agoLasted 6 minutes
Updates
Resolved
Resolved
The fault has been resolved. Should you still be experiencing issues, please contact our support team.
Investigating
Investigating
We are aware of the abnormally high latency issues affecting some services between South Africa and Europe West/UK, causing degraded performance. Engineers are currently investigating.