UrbanXConnect - Abnormal Latency - Middle East – Incident details

Experiencing degraded performance

Abnormal Latency - Middle East

Resolved
Major outage
Started 3 months agoLasted about 19 hours
Updates
  • Resolved
    Resolved

    The fault has been resolved. Should you still be experiencing issues, please contact our support team.

  • Investigating
    Investigating

    We are aware of the abnormally high latency issues affecting some services between South Africa and the Middle East, causing degraded performance. Engineers are currently investigating.